summaryrefslogtreecommitdiffstats
path: root/glow/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2020-05-19 14:23:28 +0200
committerLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2020-05-19 14:23:28 +0200
commitd4743183d40c6044ce6fa39e2a52919a32912cda (patch)
treed2dec81cd9b419262cf2aa57ad793895ccacb320 /glow/Cargo.toml
parent33448508a524db6447b380cc236be6f0d5ca8a86 (diff)
downloadiced-d4743183d40c6044ce6fa39e2a52919a32912cda.tar.gz
iced-d4743183d40c6044ce6fa39e2a52919a32912cda.tar.bz2
iced-d4743183d40c6044ce6fa39e2a52919a32912cda.zip
Draft first working version of `iced_glow` :tada:
Diffstat (limited to 'glow/Cargo.toml')
-rw-r--r--glow/Cargo.toml34
1 files changed, 34 insertions, 0 deletions
diff --git a/glow/Cargo.toml b/glow/Cargo.toml
new file mode 100644
index 00000000..e130d563
--- /dev/null
+++ b/glow/Cargo.toml
@@ -0,0 +1,34 @@
+[package]
+name = "iced_glow"
+version = "0.1.0"
+authors = ["Héctor Ramón Jiménez <hector0193@gmail.com>"]
+edition = "2018"
+description = "A glow renderer for iced"
+license = "MIT AND OFL-1.1"
+repository = "https://github.com/hecrj/iced"
+
+[dependencies]
+raw-window-handle = "0.3"
+euclid = "0.20"
+glow = "0.4"
+bytemuck = "1.2"
+glam = "0.8"
+font-kit = "0.6"
+log = "0.4"
+glyph_brush = "0.6"
+
+[dependencies.iced_native]
+version = "0.2"
+path = "../native"
+
+[dependencies.iced_style]
+version = "0.1"
+path = "../style"
+
+[dependencies.surfman]
+path = "../../surfman/surfman"
+default-features = false
+features = ["sm-raw-window-handle", "sm-x11"]
+
+[dependencies.glow_glyph]
+path = "../../glow_glyph"