summaryrefslogtreecommitdiffstats
path: root/glow/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Bingus <shankern@protonmail.com>2022-11-29 19:50:58 -0800
committerLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2023-01-09 18:52:38 +0100
commitc5cd236b7380c3689792934aeaecd2942713fa67 (patch)
treec27a0e6ecfdec7936791ee70e07ce19c713095cd /glow/Cargo.toml
parentba20ac8e49aedfa9d822d71784587d0635cec4f8 (diff)
downloadiced-c5cd236b7380c3689792934aeaecd2942713fa67.tar.gz
iced-c5cd236b7380c3689792934aeaecd2942713fa67.tar.bz2
iced-c5cd236b7380c3689792934aeaecd2942713fa67.zip
Initial profiling support for Iced.
Diffstat (limited to 'glow/Cargo.toml')
-rw-r--r--glow/Cargo.toml6
1 files changed, 6 insertions, 0 deletions
diff --git a/glow/Cargo.toml b/glow/Cargo.toml
index f586d24d..6c150a74 100644
--- a/glow/Cargo.toml
+++ b/glow/Cargo.toml
@@ -8,6 +8,7 @@ license = "MIT AND OFL-1.1"
repository = "https://github.com/iced-rs/iced"
[features]
+trace = ["iced_profiling"]
svg = ["iced_graphics/svg"]
image = ["iced_graphics/image"]
png = ["iced_graphics/png"]
@@ -42,6 +43,11 @@ version = "0.5"
path = "../graphics"
features = ["font-fallback", "font-icons", "opengl"]
+[dependencies.iced_profiling]
+version = "0.1.0"
+path = "../profiling"
+optional = true
+
[package.metadata.docs.rs]
rustdoc-args = ["--cfg", "docsrs"]
all-features = true