summaryrefslogtreecommitdiffstats
path: root/glow/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Ian Douglas Scott <idscott@system76.com>2022-10-24 17:06:02 -0700
committerLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2022-11-05 03:19:38 +0100
commit5575e6ea0897e406674e7e4239808fbf9daa07c3 (patch)
tree888f1b22926a304e7e280710312727fc4137e373 /glow/Cargo.toml
parent2c7c42ee93a61f39562590f6a75eb2dd8b220fb8 (diff)
downloadiced-5575e6ea0897e406674e7e4239808fbf9daa07c3.tar.gz
iced-5575e6ea0897e406674e7e4239808fbf9daa07c3.tar.bz2
iced-5575e6ea0897e406674e7e4239808fbf9daa07c3.zip
Add image/svg support to `iced_glow`
https://github.com/iced-rs/iced/issues/674 Uses image/svg support in `iced_graphics`. The is not currently using an atlas, and uses one texture/draw per image. This should be good enough for now; supporting images with glow is better than not supporting them, and if something else performs better, that improvement can be made without any change to the public API.
Diffstat (limited to 'glow/Cargo.toml')
-rw-r--r--glow/Cargo.toml19
1 files changed, 16 insertions, 3 deletions
diff --git a/glow/Cargo.toml b/glow/Cargo.toml
index 18215e9b..476547d4 100644
--- a/glow/Cargo.toml
+++ b/glow/Cargo.toml
@@ -8,12 +8,23 @@ license = "MIT AND OFL-1.1"
repository = "https://github.com/iced-rs/iced"
[features]
+svg = ["iced_graphics/svg"]
+image = ["image_rs", "iced_graphics/image", "png", "jpeg", "jpeg_rayon", "gif", "webp", "bmp"]
+image_rs = ["iced_graphics/image_rs"]
+png = ["iced_graphics/png"]
+jpeg = ["iced_graphics/jpeg"]
+jpeg_rayon = ["iced_graphics/jpeg_rayon"]
+gif = ["iced_graphics/gif"]
+webp = ["iced_graphics/webp"]
+pnm = ["iced_graphics/pnm"]
+ico = ["iced_graphics/ico"]
+bmp = ["iced_graphics/bmp"]
+hdr = ["iced_graphics/hdr"]
+dds = ["iced_graphics/dds"]
+farbfeld = ["iced_graphics/farbfeld"]
canvas = ["iced_graphics/canvas"]
qr_code = ["iced_graphics/qr_code"]
default_system_font = ["iced_graphics/font-source"]
-# Not supported yet!
-image = []
-svg = []
[dependencies]
glow = "0.11.1"
@@ -22,6 +33,8 @@ glyph_brush = "0.7"
euclid = "0.22"
bytemuck = "1.4"
log = "0.4"
+kamadak-exif = "0.5"
+bitflags = "1.2"
[dependencies.iced_native]
version = "0.5"