summaryrefslogtreecommitdiffstats
path: root/glow/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón <hector0193@gmail.com>2022-11-05 04:37:59 +0100
committerLibravatar GitHub <noreply@github.com>2022-11-05 04:37:59 +0100
commit370fa14efb8d41bcf81e4a0ead6a9ab7ab750bee (patch)
tree6a434e6bc8c3a95065faafa533cf1d5e2318cc06 /glow/Cargo.toml
parent7b129917281baaa6688158c303922f94341ab69f (diff)
parent078cadfed0e67560d9047d84435e87b8671c5992 (diff)
downloadiced-370fa14efb8d41bcf81e4a0ead6a9ab7ab750bee.tar.gz
iced-370fa14efb8d41bcf81e4a0ead6a9ab7ab750bee.tar.bz2
iced-370fa14efb8d41bcf81e4a0ead6a9ab7ab750bee.zip
Merge pull request #1485 from ids1024/glow-image
Glow image rendering support; move image/svg code to iced_graphics
Diffstat (limited to 'glow/Cargo.toml')
-rw-r--r--glow/Cargo.toml16
1 files changed, 13 insertions, 3 deletions
diff --git a/glow/Cargo.toml b/glow/Cargo.toml
index 18215e9b..a50fd375 100644
--- a/glow/Cargo.toml
+++ b/glow/Cargo.toml
@@ -8,12 +8,22 @@ license = "MIT AND OFL-1.1"
repository = "https://github.com/iced-rs/iced"
[features]
+svg = ["iced_graphics/svg"]
+image = ["iced_graphics/image"]
+png = ["iced_graphics/png"]
+jpeg = ["iced_graphics/jpeg"]
+jpeg_rayon = ["iced_graphics/jpeg_rayon"]
+gif = ["iced_graphics/gif"]
+webp = ["iced_graphics/webp"]
+pnm = ["iced_graphics/pnm"]
+ico = ["iced_graphics/ico"]
+bmp = ["iced_graphics/bmp"]
+hdr = ["iced_graphics/hdr"]
+dds = ["iced_graphics/dds"]
+farbfeld = ["iced_graphics/farbfeld"]
canvas = ["iced_graphics/canvas"]
qr_code = ["iced_graphics/qr_code"]
default_system_font = ["iced_graphics/font-source"]
-# Not supported yet!
-image = []
-svg = []
[dependencies]
glow = "0.11.1"