summaryrefslogtreecommitdiffstats
path: root/futures/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Jayce Fayne <jayce.fayne@mailbox.org>2021-01-13 01:48:35 +0100
committerLibravatar Jayce Fayne <jayce.fayne@mailbox.org>2021-01-14 12:28:02 +0100
commitb2415eee61063d5c2b220d7b7a513d1952ce2be1 (patch)
tree2a0429981aa745132cb103d9d9bb75972e0c27b6 /futures/Cargo.toml
parent92d647d1a6145e19ef9f540e02faef6a892f51fa (diff)
downloadiced-b2415eee61063d5c2b220d7b7a513d1952ce2be1.tar.gz
iced-b2415eee61063d5c2b220d7b7a513d1952ce2be1.tar.bz2
iced-b2415eee61063d5c2b220d7b7a513d1952ce2be1.zip
Add `smol` async runtime
Diffstat (limited to 'futures/Cargo.toml')
-rw-r--r--futures/Cargo.toml4
1 files changed, 4 insertions, 0 deletions
diff --git a/futures/Cargo.toml b/futures/Cargo.toml
index 92b504a6..c42cc603 100644
--- a/futures/Cargo.toml
+++ b/futures/Cargo.toml
@@ -36,6 +36,10 @@ version = "1.0"
optional = true
features = ["unstable"]
+[target.'cfg(not(target_arch = "wasm32"))'.dependencies.smol]
+version = "1.0"
+optional = true
+
[target.'cfg(target_arch = "wasm32")'.dependencies]
wasm-bindgen-futures = "0.4"