summaryrefslogtreecommitdiffstats
path: root/futures/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón <hector0193@gmail.com>2020-11-25 04:24:44 +0100
committerLibravatar GitHub <noreply@github.com>2020-11-25 04:24:44 +0100
commit87c9df294c79d73ff67a8d9a036cf9ddff24c52f (patch)
tree167a3a63519d20e67cf227441b938d8a9b0b584d /futures/Cargo.toml
parent8f081bad7756e16a4eb0ca4dcb1144fc47de5e9b (diff)
parent782dd2f5222bfef5e12aa576a821da21126505b7 (diff)
downloadiced-87c9df294c79d73ff67a8d9a036cf9ddff24c52f.tar.gz
iced-87c9df294c79d73ff67a8d9a036cf9ddff24c52f.tar.bz2
iced-87c9df294c79d73ff67a8d9a036cf9ddff24c52f.zip
Merge pull request #595 from valbendan/master
upgrade tokio to latest version(v0.3)
Diffstat (limited to 'futures/Cargo.toml')
-rw-r--r--futures/Cargo.toml8
1 files changed, 7 insertions, 1 deletions
diff --git a/futures/Cargo.toml b/futures/Cargo.toml
index 275d0391..7854dbb0 100644
--- a/futures/Cargo.toml
+++ b/futures/Cargo.toml
@@ -19,11 +19,17 @@ log = "0.4"
[dependencies.futures]
version = "0.3"
-[target.'cfg(not(target_arch = "wasm32"))'.dependencies.tokio]
+[target.'cfg(not(target_arch = "wasm32"))'.dependencies.tokio_old]
+package = "tokio"
version = "0.2"
optional = true
features = ["rt-core", "rt-threaded", "time", "stream"]
+[target.'cfg(not(target_arch = "wasm32"))'.dependencies.tokio]
+version = "0.3"
+optional = true
+features = ["rt-multi-thread", "time", "stream"]
+
[target.'cfg(not(target_arch = "wasm32"))'.dependencies.async-std]
version = "1.0"
optional = true