summaryrefslogtreecommitdiffstats
path: root/futures/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2020-11-25 03:06:24 +0100
committerLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2020-11-25 03:06:24 +0100
commit782dd2f5222bfef5e12aa576a821da21126505b7 (patch)
treeef43d15531134d4c92dedca14682d70d0c614a00 /futures/Cargo.toml
parenta4ad1b297e97d6c3efc196681822f127efc954cc (diff)
downloadiced-782dd2f5222bfef5e12aa576a821da21126505b7.tar.gz
iced-782dd2f5222bfef5e12aa576a821da21126505b7.tar.bz2
iced-782dd2f5222bfef5e12aa576a821da21126505b7.zip
Introduce `tokio_old` feature
This feature allows users to rely on the `0.2` version of `tokio` while the async ecosystem upgrades to the latest version.
Diffstat (limited to 'futures/Cargo.toml')
-rw-r--r--futures/Cargo.toml6
1 files changed, 6 insertions, 0 deletions
diff --git a/futures/Cargo.toml b/futures/Cargo.toml
index 078c96aa..7854dbb0 100644
--- a/futures/Cargo.toml
+++ b/futures/Cargo.toml
@@ -19,6 +19,12 @@ log = "0.4"
[dependencies.futures]
version = "0.3"
+[target.'cfg(not(target_arch = "wasm32"))'.dependencies.tokio_old]
+package = "tokio"
+version = "0.2"
+optional = true
+features = ["rt-core", "rt-threaded", "time", "stream"]
+
[target.'cfg(not(target_arch = "wasm32"))'.dependencies.tokio]
version = "0.3"
optional = true