summaryrefslogtreecommitdiffstats
path: root/futures/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2020-01-19 11:08:47 +0100
committerLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2020-01-19 11:08:47 +0100
commit35760ac68f06e783e64e9048aff0fff6df1c09cf (patch)
tree0ed42bd6c9417f7adb42f1dae62e17bfaab74319 /futures/Cargo.toml
parentb8b0d97525aaa2641d8493aa65e3108d70c1560a (diff)
downloadiced-35760ac68f06e783e64e9048aff0fff6df1c09cf.tar.gz
iced-35760ac68f06e783e64e9048aff0fff6df1c09cf.tar.bz2
iced-35760ac68f06e783e64e9048aff0fff6df1c09cf.zip
Make `thread-pool` optional in `iced_futures`
Diffstat (limited to 'futures/Cargo.toml')
-rw-r--r--futures/Cargo.toml4
1 files changed, 3 insertions, 1 deletions
diff --git a/futures/Cargo.toml b/futures/Cargo.toml
index fe0d378c..5b303e01 100644
--- a/futures/Cargo.toml
+++ b/futures/Cargo.toml
@@ -10,12 +10,14 @@ documentation = "https://docs.rs/iced_futures"
keywords = ["gui", "ui", "graphics", "interface", "futures"]
categories = ["gui"]
+[features]
+thread-pool = ["futures/thread-pool"]
+
[dependencies]
log = "0.4"
[dependencies.futures]
version = "0.3"
-features = ["thread-pool"]
[dependencies.tokio]
version = "0.2"