summaryrefslogtreecommitdiffstats
path: root/futures/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2023-09-04 12:58:41 +0200
committerLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2023-09-04 13:08:17 +0200
commitf468e25d0c67a01ee79d892f6e8ba9be019f06c7 (patch)
treec099dc3a7c4ef6faa5ce762832a286d0a55ec316 /futures/Cargo.toml
parenta56b25b9096d47ada3c4349f5b91110dfaa92bf6 (diff)
downloadiced-f468e25d0c67a01ee79d892f6e8ba9be019f06c7.tar.gz
iced-f468e25d0c67a01ee79d892f6e8ba9be019f06c7.tar.bz2
iced-f468e25d0c67a01ee79d892f6e8ba9be019f06c7.zip
Use workspace dependencies and package inheritance
We are also taking this as a chance to synchronize the versions of all the crates! Because of this, we will skip the `0.11` version.
Diffstat (limited to '')
-rw-r--r--futures/Cargo.toml61
1 files changed, 27 insertions, 34 deletions
diff --git a/futures/Cargo.toml b/futures/Cargo.toml
index 044827c2..69a915e4 100644
--- a/futures/Cargo.toml
+++ b/futures/Cargo.toml
@@ -1,47 +1,40 @@
[package]
name = "iced_futures"
-version = "0.7.0"
-authors = ["Héctor Ramón Jiménez <hector0193@gmail.com>"]
-edition = "2021"
-description = "Commands, subscriptions, and runtimes for Iced"
-license = "MIT"
-repository = "https://github.com/iced-rs/iced"
-documentation = "https://docs.rs/iced_futures"
-keywords = ["gui", "ui", "graphics", "interface", "futures"]
-categories = ["gui"]
+description = "Commands, subscriptions, and future executors for iced"
+version.workspace = true
+edition.workspace = true
+authors.workspace = true
+license.workspace = true
+repository.workspace = true
+homepage.workspace = true
+categories.workspace = true
+keywords.workspace = true
+
+[package.metadata.docs.rs]
+rustdoc-args = ["--cfg", "docsrs"]
+all-features = true
[features]
thread-pool = ["futures/thread-pool"]
[dependencies]
-log = "0.4"
-
-[dependencies.iced_core]
-version = "0.10"
-path = "../core"
+iced_core.workspace = true
-[dependencies.futures]
-version = "0.3"
+futures.workspace = true
+log.workspace = true
-[target.'cfg(not(target_arch = "wasm32"))'.dependencies.tokio]
-package = "tokio"
-version = "1.0"
-optional = true
-features = ["rt", "rt-multi-thread", "time"]
+[target.'cfg(not(target_arch = "wasm32"))'.dependencies]
+async-std.workspace = true
+async-std.optional = true
+async-std.features = ["unstable"]
-[target.'cfg(not(target_arch = "wasm32"))'.dependencies.async-std]
-version = "1.0"
-optional = true
-features = ["unstable"]
+smol.workspace = true
+smol.optional = true
-[target.'cfg(not(target_arch = "wasm32"))'.dependencies.smol]
-version = "1.2"
-optional = true
+tokio.workspace = true
+tokio.optional = true
+tokio.features = ["rt", "rt-multi-thread", "time"]
[target.'cfg(target_arch = "wasm32")'.dependencies]
-wasm-bindgen-futures = "0.4"
-wasm-timer = "0.2"
-
-[package.metadata.docs.rs]
-rustdoc-args = ["--cfg", "docsrs"]
-all-features = true
+wasm-bindgen-futures.workspace = true
+wasm-timer.workspace = true