summaryrefslogtreecommitdiffstats
path: root/examples/websocket/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2022-01-16 15:50:19 +0700
committerLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2022-01-16 15:50:19 +0700
commitdc50a2830ab553dfc5dfc28d4fd1af6b3981c656 (patch)
tree4ff8bce15f88a0ca610551fdd81afa968f7fda58 /examples/websocket/Cargo.toml
parent2f557731f313ccc94b5d0ebb4ee5603624670daf (diff)
downloadiced-dc50a2830ab553dfc5dfc28d4fd1af6b3981c656.tar.gz
iced-dc50a2830ab553dfc5dfc28d4fd1af6b3981c656.tar.bz2
iced-dc50a2830ab553dfc5dfc28d4fd1af6b3981c656.zip
Draft `websocket` example :tada:
Diffstat (limited to 'examples/websocket/Cargo.toml')
-rw-r--r--examples/websocket/Cargo.toml22
1 files changed, 22 insertions, 0 deletions
diff --git a/examples/websocket/Cargo.toml b/examples/websocket/Cargo.toml
new file mode 100644
index 00000000..6b4d9d10
--- /dev/null
+++ b/examples/websocket/Cargo.toml
@@ -0,0 +1,22 @@
+[package]
+name = "websocket"
+version = "0.1.0"
+authors = ["Héctor Ramón Jiménez <hector0193@gmail.com>"]
+edition = "2018"
+publish = false
+
+[dependencies]
+iced = { path = "../..", features = ["tokio", "debug"] }
+iced_native = { path = "../../native" }
+iced_futures = { path = "../../futures" }
+
+[dependencies.async-tungstenite]
+version = "0.16"
+features = ["tokio-rustls-webpki-roots"]
+
+[dependencies.tokio]
+version = "1"
+features = ["time"]
+
+[dependencies.warp]
+version = "0.3"