summaryrefslogtreecommitdiffstats
path: root/examples/websocket/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón <hector0193@gmail.com>2022-01-17 21:46:17 +0700
committerLibravatar GitHub <noreply@github.com>2022-01-17 21:46:17 +0700
commit92a699b97dacd4c40316b67e20b6a3a777a1de64 (patch)
tree06ab57aaf4dada3a5b7cef6f331a22c47183ac5e /examples/websocket/Cargo.toml
parentb7bc169120d3447ead238e974007027a5152d341 (diff)
parent5ce8653fb51c035e0a6fe1ba7ab363018cdf107b (diff)
downloadiced-92a699b97dacd4c40316b67e20b6a3a777a1de64.tar.gz
iced-92a699b97dacd4c40316b67e20b6a3a777a1de64.tar.bz2
iced-92a699b97dacd4c40316b67e20b6a3a777a1de64.zip
Merge pull request #1198 from iced-rs/subscription-helpers
`websocket` example and helpers to create custom subscriptions
Diffstat (limited to 'examples/websocket/Cargo.toml')
-rw-r--r--examples/websocket/Cargo.toml22
1 files changed, 22 insertions, 0 deletions
diff --git a/examples/websocket/Cargo.toml b/examples/websocket/Cargo.toml
new file mode 100644
index 00000000..6b4d9d10
--- /dev/null
+++ b/examples/websocket/Cargo.toml
@@ -0,0 +1,22 @@
+[package]
+name = "websocket"
+version = "0.1.0"
+authors = ["Héctor Ramón Jiménez <hector0193@gmail.com>"]
+edition = "2018"
+publish = false
+
+[dependencies]
+iced = { path = "../..", features = ["tokio", "debug"] }
+iced_native = { path = "../../native" }
+iced_futures = { path = "../../futures" }
+
+[dependencies.async-tungstenite]
+version = "0.16"
+features = ["tokio-rustls-webpki-roots"]
+
+[dependencies.tokio]
+version = "1"
+features = ["time"]
+
+[dependencies.warp]
+version = "0.3"