summaryrefslogtreecommitdiffstats
path: root/examples/tour/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Thomas <thomasbirke@gmx.de>2023-09-09 14:09:48 +0200
committerLibravatar Thomas <thomasbirke@gmx.de>2023-09-09 14:09:48 +0200
commite562544807b196dafac9195ea8137958698755e5 (patch)
tree4cd4040887ee19ee6ebb89cea344d54f8176ca5f /examples/tour/Cargo.toml
parent9c2ad457d80e8254955396ad034df0dd5f2b59b3 (diff)
downloadiced-e562544807b196dafac9195ea8137958698755e5.tar.gz
iced-e562544807b196dafac9195ea8137958698755e5.tar.bz2
iced-e562544807b196dafac9195ea8137958698755e5.zip
Add logging for web in tour example
Diffstat (limited to 'examples/tour/Cargo.toml')
-rw-r--r--examples/tour/Cargo.toml5
1 files changed, 5 insertions, 0 deletions
diff --git a/examples/tour/Cargo.toml b/examples/tour/Cargo.toml
index 9de017ce..11920e0d 100644
--- a/examples/tour/Cargo.toml
+++ b/examples/tour/Cargo.toml
@@ -9,8 +9,13 @@ publish = false
iced.workspace = true
iced.features = ["image", "debug"]
+[target.'cfg(not(target_arch = "wasm32"))'.dependencies]
tracing-subscriber = "0.3"
[target.'cfg(target_arch = "wasm32")'.dependencies]
iced.workspace = true
iced.features = ["image", "debug", "webgl"]
+
+console_error_panic_hook = "0.1"
+console_log = "1.0"
+log.workspace = true