summaryrefslogtreecommitdiffstats
path: root/examples/todos/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2020-02-06 03:06:39 +0100
committerLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2020-02-06 03:06:39 +0100
commite8316b208705910958152b2ef6c4c5d7110b4e6c (patch)
tree994e72b3f0e852a93012164177ea8d98de116fcf /examples/todos/Cargo.toml
parent57aed1d5c61a14fa6337e9f838fc519efdd75e06 (diff)
downloadiced-e8316b208705910958152b2ef6c4c5d7110b4e6c.tar.gz
iced-e8316b208705910958152b2ef6c4c5d7110b4e6c.tar.bz2
iced-e8316b208705910958152b2ef6c4c5d7110b4e6c.zip
Allow `todos` example to compile to `wasm32`
Diffstat (limited to '')
-rw-r--r--examples/todos/Cargo.toml4
1 files changed, 3 insertions, 1 deletions
diff --git a/examples/todos/Cargo.toml b/examples/todos/Cargo.toml
index 21acd5d6..cfb8e97d 100644
--- a/examples/todos/Cargo.toml
+++ b/examples/todos/Cargo.toml
@@ -8,9 +8,11 @@ publish = false
[dependencies]
iced = { path = "../.." }
iced_futures = { path = "../../futures", features = ["async-std"] }
-async-std = "1.0"
serde = { version = "1.0", features = ["derive"] }
serde_json = "1.0"
+
+[target.'cfg(not(target_arch = "wasm32"))'.dependencies]
+async-std = "1.0"
directories = "2.0"
[package.metadata.deb]