summaryrefslogtreecommitdiffstats
path: root/examples/todos/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2020-02-06 05:56:23 +0100
committerLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2020-02-06 05:56:23 +0100
commit36e617ae70cc7a86ce998cbd61f6aa702bb42933 (patch)
treec3a4ec76931c8153c932c364fa393e25d39d74f0 /examples/todos/Cargo.toml
parent679d758627f6500de4b2220c0dba3460871b83b4 (diff)
downloadiced-36e617ae70cc7a86ce998cbd61f6aa702bb42933.tar.gz
iced-36e617ae70cc7a86ce998cbd61f6aa702bb42933.tar.bz2
iced-36e617ae70cc7a86ce998cbd61f6aa702bb42933.zip
Implement local storage for `todos` example in Wasm
Diffstat (limited to '')
-rw-r--r--examples/todos/Cargo.toml4
1 files changed, 4 insertions, 0 deletions
diff --git a/examples/todos/Cargo.toml b/examples/todos/Cargo.toml
index c905fc38..f945cde5 100644
--- a/examples/todos/Cargo.toml
+++ b/examples/todos/Cargo.toml
@@ -14,6 +14,10 @@ serde_json = "1.0"
async-std = "1.0"
directories = "2.0"
+[target.'cfg(target_arch = "wasm32")'.dependencies]
+web-sys = { version = "0.3", features = ["Window", "Storage"] }
+wasm-timer = "0.2"
+
[package.metadata.deb]
assets = [
["target/release/todos", "usr/bin/iced-todos", "755"],