summaryrefslogtreecommitdiffstats
path: root/examples/pokedex/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón <hector0193@gmail.com>2023-09-07 03:30:35 +0200
committerLibravatar GitHub <noreply@github.com>2023-09-07 03:30:35 +0200
commitd1822ad8116604590b7e9be51fc0aea4292a0760 (patch)
tree547c601fbcba58409225bc853c27286a2747a99d /examples/pokedex/Cargo.toml
parentc8fed143eb14d790da0592c5e24c741f6fda101e (diff)
parentd315e27451d46a815d18ed6037547d178413ede7 (diff)
downloadiced-d1822ad8116604590b7e9be51fc0aea4292a0760.tar.gz
iced-d1822ad8116604590b7e9be51fc0aea4292a0760.tar.bz2
iced-d1822ad8116604590b7e9be51fc0aea4292a0760.zip
Merge pull request #2069 from iced-rs/use-workspace-dependencies
Use workspace dependencies and package inheritance
Diffstat (limited to 'examples/pokedex/Cargo.toml')
-rw-r--r--examples/pokedex/Cargo.toml11
1 files changed, 8 insertions, 3 deletions
diff --git a/examples/pokedex/Cargo.toml b/examples/pokedex/Cargo.toml
index e99fc0c3..bf7e1e35 100644
--- a/examples/pokedex/Cargo.toml
+++ b/examples/pokedex/Cargo.toml
@@ -6,7 +6,9 @@ edition = "2021"
publish = false
[dependencies]
-iced = { path = "../..", features = ["image", "debug", "tokio"] }
+iced.workspace = true
+iced.features = ["image", "debug", "tokio"]
+
serde_json = "1.0"
[dependencies.serde]
@@ -19,5 +21,8 @@ default-features = false
features = ["json", "rustls-tls"]
[dependencies.rand]
-version = "0.7"
-features = ["wasm-bindgen"]
+version = "0.8"
+
+[dependencies.getrandom]
+version = "0.2"
+features = ["js"]