summaryrefslogtreecommitdiffstats
path: root/examples/pokedex/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2020-02-05 04:15:45 +0100
committerLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2020-02-05 04:15:45 +0100
commit9df3fb13c7b0372f64ff7bd9073769833689de5b (patch)
tree97906f18b796d7cbf6d6d12cf703e75602f2ae90 /examples/pokedex/Cargo.toml
parentca213922d043a5532d9ab352c0d54bfca7563871 (diff)
downloadiced-9df3fb13c7b0372f64ff7bd9073769833689de5b.tar.gz
iced-9df3fb13c7b0372f64ff7bd9073769833689de5b.tar.bz2
iced-9df3fb13c7b0372f64ff7bd9073769833689de5b.zip
Make `pokedex` example work on Wasm
Diffstat (limited to 'examples/pokedex/Cargo.toml')
-rw-r--r--examples/pokedex/Cargo.toml9
1 files changed, 7 insertions, 2 deletions
diff --git a/examples/pokedex/Cargo.toml b/examples/pokedex/Cargo.toml
index b96eda91..f8668be0 100644
--- a/examples/pokedex/Cargo.toml
+++ b/examples/pokedex/Cargo.toml
@@ -8,7 +8,12 @@ publish = false
[dependencies]
iced = { path = "../..", features = ["image", "debug"] }
iced_futures = { path = "../../futures", features = ["tokio"] }
-reqwest = { version = "0.10", features = ["json"] }
-rand = "0.7"
serde = { version = "1.0", features = ["derive"] }
serde_json = "1.0"
+rand = { version = "0.7", features = ["wasm-bindgen"] }
+
+[dependencies.reqwest]
+version = "0.10"
+git = "https://github.com/hecrj/reqwest.git"
+branch = "feature/wasm-deserialize-json"
+features = ["json"]