summaryrefslogtreecommitdiffstats
path: root/examples/integration_wgpu/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Vladyslav Nikonov <mail@pacmancoder.xyz>2021-10-21 22:42:14 +0300
committerLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2022-01-28 21:37:14 +0700
commitbdca20fc4a3e8f6bd8ffb59de75e6ca0f8a94b6a (patch)
tree8ea0d2ff0a0d780ff763d7491fc67878f549a615 /examples/integration_wgpu/Cargo.toml
parentc75ed37148b019358b0297171cf31b2577eeb9ae (diff)
downloadiced-bdca20fc4a3e8f6bd8ffb59de75e6ca0f8a94b6a.tar.gz
iced-bdca20fc4a3e8f6bd8ffb59de75e6ca0f8a94b6a.tar.bz2
iced-bdca20fc4a3e8f6bd8ffb59de75e6ca0f8a94b6a.zip
Experimental wgpu WebGL backend support
- Added missing `draw_cache_align_4x4` call for `brush_glyph` on wasm32 target - Added WebGL support to `integratio_wgpu` example - Fixed test.yml CI workflow - Removed spir-v shader in `integration_wgpu`; Fixed formatting - Removed redundant `BoxStream` typedef
Diffstat (limited to 'examples/integration_wgpu/Cargo.toml')
-rw-r--r--examples/integration_wgpu/Cargo.toml13
1 files changed, 12 insertions, 1 deletions
diff --git a/examples/integration_wgpu/Cargo.toml b/examples/integration_wgpu/Cargo.toml
index a088dd1b..0ded1a56 100644
--- a/examples/integration_wgpu/Cargo.toml
+++ b/examples/integration_wgpu/Cargo.toml
@@ -7,5 +7,16 @@ publish = false
[dependencies]
iced_winit = { path = "../../winit" }
-iced_wgpu = { path = "../../wgpu", features = ["spirv"] }
+iced_wgpu = { path = "../../wgpu", features = ["webgl"] }
env_logger = "0.8"
+
+[target.'cfg(target_arch = "wasm32")'.dependencies]
+console_error_panic_hook = "0.1.7"
+console_log = "0.2.0"
+log = "0.4"
+wasm-bindgen = "0.2"
+web-sys = { version = "0.3", features = ["Element", "HtmlCanvasElement", "Window", "Document"] }
+# This dependency a little bit quirky, it is deep in the tree and without `js` feature it
+# refuses to work with `wasm32-unknown-unknown target`. Unfortunately, we need this patch
+# to make it work
+getrandom = { version = "0.2", features = ["js"] }