summaryrefslogtreecommitdiffstats
path: root/examples/game_of_life/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2023-09-04 12:58:41 +0200
committerLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2023-09-04 13:08:17 +0200
commitf468e25d0c67a01ee79d892f6e8ba9be019f06c7 (patch)
treec099dc3a7c4ef6faa5ce762832a286d0a55ec316 /examples/game_of_life/Cargo.toml
parenta56b25b9096d47ada3c4349f5b91110dfaa92bf6 (diff)
downloadiced-f468e25d0c67a01ee79d892f6e8ba9be019f06c7.tar.gz
iced-f468e25d0c67a01ee79d892f6e8ba9be019f06c7.tar.bz2
iced-f468e25d0c67a01ee79d892f6e8ba9be019f06c7.zip
Use workspace dependencies and package inheritance
We are also taking this as a chance to synchronize the versions of all the crates! Because of this, we will skip the `0.11` version.
Diffstat (limited to 'examples/game_of_life/Cargo.toml')
-rw-r--r--examples/game_of_life/Cargo.toml10
1 files changed, 6 insertions, 4 deletions
diff --git a/examples/game_of_life/Cargo.toml b/examples/game_of_life/Cargo.toml
index 6de45db6..f8d21c65 100644
--- a/examples/game_of_life/Cargo.toml
+++ b/examples/game_of_life/Cargo.toml
@@ -6,8 +6,10 @@ edition = "2021"
publish = false
[dependencies]
-iced = { path = "../..", features = ["canvas", "tokio", "debug"] }
-tokio = { version = "1.0", features = ["sync"] }
+iced.workspace = true
+iced.features = ["debug", "canvas", "tokio"]
+
itertools = "0.9"
-rustc-hash = "1.1"
-env_logger = "0.10"
+rustc-hash.workspace = true
+tokio = { workspace = true, features = ["sync"] }
+tracing-subscriber = "0.3"