summaryrefslogtreecommitdiffstats
path: root/examples/gallery/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón Jiménez <hector@hecrj.dev>2025-01-27 05:01:43 +0100
committerLibravatar Héctor Ramón Jiménez <hector@hecrj.dev>2025-01-27 05:01:43 +0100
commite2c52c9728cb03d01b33388a8159db9bd9eac04c (patch)
treeb228e5b08e614887c5c70546427487eb2266358c /examples/gallery/Cargo.toml
parent890d852e0544ffbf06ac7eb8c3904dc04a0008cf (diff)
downloadiced-e2c52c9728cb03d01b33388a8159db9bd9eac04c.tar.gz
iced-e2c52c9728cb03d01b33388a8159db9bd9eac04c.tar.bz2
iced-e2c52c9728cb03d01b33388a8159db9bd9eac04c.zip
Implement AI `gallery` example :tada:
It displays the most popular daily images of Civitai!
Diffstat (limited to 'examples/gallery/Cargo.toml')
-rw-r--r--examples/gallery/Cargo.toml23
1 files changed, 23 insertions, 0 deletions
diff --git a/examples/gallery/Cargo.toml b/examples/gallery/Cargo.toml
new file mode 100644
index 00000000..573389b1
--- /dev/null
+++ b/examples/gallery/Cargo.toml
@@ -0,0 +1,23 @@
+[package]
+name = "gallery"
+version = "0.1.0"
+authors = ["Héctor Ramón Jiménez <hector0193@gmail.com>"]
+edition = "2021"
+publish = false
+
+[dependencies]
+iced.workspace = true
+iced.features = ["tokio", "image", "web-colors", "debug"]
+
+reqwest.version = "0.12"
+reqwest.features = ["json"]
+
+serde.version = "1.0"
+serde.features = ["derive"]
+
+bytes.workspace = true
+image.workspace = true
+tokio.workspace = true
+
+[lints]
+workspace = true