summaryrefslogtreecommitdiffstats
path: root/examples/download_progress/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Folyd <lyshuhow@gmail.com>2021-02-13 05:00:52 +0800
committerLibravatar GitHub <noreply@github.com>2021-02-12 22:00:52 +0100
commit9f5c2eb0c43daa61b19769322cf3692b29e0ac0f (patch)
tree2486e4c8b690800d4d9a2bb3c62f14b4f5156ba5 /examples/download_progress/Cargo.toml
parent9e453843b26f2f73228316334298a4c608b2f050 (diff)
downloadiced-9f5c2eb0c43daa61b19769322cf3692b29e0ac0f.tar.gz
iced-9f5c2eb0c43daa61b19769322cf3692b29e0ac0f.tar.bz2
iced-9f5c2eb0c43daa61b19769322cf3692b29e0ac0f.zip
Improve download_progress example (#283)
* Add advanced download example * Rename to task fields and variables * Cargo fmt advanced_download/src/download.rs * Add progress bar for advanced download example * Merge two download examples to single one * Apply great review suggestions * Change to url::Url instead of plain String * Simplify `download_progress` example * Update `README` of `download_progress` example Co-authored-by: Héctor Ramón Jiménez <hector0193@gmail.com>
Diffstat (limited to 'examples/download_progress/Cargo.toml')
-rw-r--r--examples/download_progress/Cargo.toml6
1 files changed, 3 insertions, 3 deletions
diff --git a/examples/download_progress/Cargo.toml b/examples/download_progress/Cargo.toml
index 4b05e7dc..d3c578b1 100644
--- a/examples/download_progress/Cargo.toml
+++ b/examples/download_progress/Cargo.toml
@@ -1,12 +1,12 @@
[package]
name = "download_progress"
version = "0.1.0"
-authors = ["Songtronix <contact@songtronix.com>"]
+authors = ["Songtronix <contact@songtronix.com>", "Folyd <lyshuhow@gmail.com>"]
edition = "2018"
publish = false
[dependencies]
-iced = { path = "../..", features = ["tokio_old"] }
+iced = { path = "../..", features = ["tokio"] }
iced_native = { path = "../../native" }
iced_futures = { path = "../../futures" }
-reqwest = "0.10"
+reqwest = "0.11"