summaryrefslogtreecommitdiffstats
path: root/examples/download_progress/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2020-03-23 20:34:16 +0100
committerLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2020-03-23 20:34:16 +0100
commit30c7db3f25d12461f2dec493f92c3f3282bd264d (patch)
treef7e1d6df642715d033686b86f41d77ebf1ac810e /examples/download_progress/Cargo.toml
parentfff333f89ba99f32171641f0e8d78c9cdfe291b4 (diff)
downloadiced-30c7db3f25d12461f2dec493f92c3f3282bd264d.tar.gz
iced-30c7db3f25d12461f2dec493f92c3f3282bd264d.tar.bz2
iced-30c7db3f25d12461f2dec493f92c3f3282bd264d.zip
Improve `download_progress` example
- Use `reqwest` with `Response::chunk` to notify progress. - Turn example state into an enum
Diffstat (limited to 'examples/download_progress/Cargo.toml')
-rw-r--r--examples/download_progress/Cargo.toml5
1 files changed, 2 insertions, 3 deletions
diff --git a/examples/download_progress/Cargo.toml b/examples/download_progress/Cargo.toml
index ce0435fd..34e6a132 100644
--- a/examples/download_progress/Cargo.toml
+++ b/examples/download_progress/Cargo.toml
@@ -6,8 +6,7 @@ edition = "2018"
publish = false
[dependencies]
-iced = { path = "../.." }
+iced = { path = "../..", features = ["tokio"] }
iced_native = { path = "../../native" }
iced_futures = { path = "../../futures" }
-async-std = { version = "1.0", features = ["unstable"] }
-isahc = "0.9.1"
+reqwest = "0.10"