summaryrefslogtreecommitdiffstats
path: root/examples/clock/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Skygrango <skygrango@gmail.com>2024-05-03 13:04:39 +0800
committerLibravatar Skygrango <skygrango@gmail.com>2024-05-03 13:10:46 +0800
commitf9124470b4b6adca19094dd0f5e663efd9471ec3 (patch)
treef3db3654209b1f5ae0a27d2ed3b56d24ab562c60 /examples/clock/Cargo.toml
parentfe240a93aacd15bd3fa75876054753a53bda9054 (diff)
downloadiced-f9124470b4b6adca19094dd0f5e663efd9471ec3.tar.gz
iced-f9124470b4b6adca19094dd0f5e663efd9471ec3.tar.bz2
iced-f9124470b4b6adca19094dd0f5e663efd9471ec3.zip
Fix `clock` example doesn't get the correct local time under unix system
There is a long-standing problem (https://github.com/time-rs/time/issues/293) that has not yet been solved by time-rs Switch to chrono as it seemed to solve the problem (https://github.com/chronotope/chrono/pull/677)
Diffstat (limited to 'examples/clock/Cargo.toml')
-rw-r--r--examples/clock/Cargo.toml3
1 files changed, 1 insertions, 2 deletions
diff --git a/examples/clock/Cargo.toml b/examples/clock/Cargo.toml
index dc2e5382..2fddc7da 100644
--- a/examples/clock/Cargo.toml
+++ b/examples/clock/Cargo.toml
@@ -8,6 +8,5 @@ publish = false
[dependencies]
iced.workspace = true
iced.features = ["canvas", "tokio", "debug"]
-
-time = { version = "0.3", features = ["local-offset"] }
+chrono = { version = "0.4", features = [ "clock" ] }
tracing-subscriber = "0.3"