summaryrefslogtreecommitdiffstats
path: root/core/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2023-09-04 12:58:41 +0200
committerLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2023-09-04 13:08:17 +0200
commitf468e25d0c67a01ee79d892f6e8ba9be019f06c7 (patch)
treec099dc3a7c4ef6faa5ce762832a286d0a55ec316 /core/Cargo.toml
parenta56b25b9096d47ada3c4349f5b91110dfaa92bf6 (diff)
downloadiced-f468e25d0c67a01ee79d892f6e8ba9be019f06c7.tar.gz
iced-f468e25d0c67a01ee79d892f6e8ba9be019f06c7.tar.bz2
iced-f468e25d0c67a01ee79d892f6e8ba9be019f06c7.zip
Use workspace dependencies and package inheritance
We are also taking this as a chance to synchronize the versions of all the crates! Because of this, we will skip the `0.11` version.
Diffstat (limited to 'core/Cargo.toml')
-rw-r--r--core/Cargo.toml30
1 files changed, 16 insertions, 14 deletions
diff --git a/core/Cargo.toml b/core/Cargo.toml
index 8bb37309..8859e91e 100644
--- a/core/Cargo.toml
+++ b/core/Cargo.toml
@@ -1,24 +1,26 @@
[package]
name = "iced_core"
-version = "0.10.0"
-authors = ["Héctor Ramón Jiménez <hector0193@gmail.com>"]
-edition = "2021"
-description = "The essential concepts of Iced"
-license = "MIT"
-repository = "https://github.com/iced-rs/iced"
+description = "The essential ideas of iced"
+version.workspace = true
+edition.workspace = true
+authors.workspace = true
+license.workspace = true
+repository.workspace = true
+homepage.workspace = true
+categories.workspace = true
+keywords.workspace = true
[dependencies]
-bitflags = "1.2"
-thiserror = "1"
-log = "0.4.17"
-twox-hash = { version = "1.5", default-features = false }
+bitflags.workspace = true
+log.workspace = true
+thiserror.workspace = true
+twox-hash.workspace = true
-[dependencies.palette]
-version = "0.7"
-optional = true
+palette.workspace = true
+palette.optional = true
[target.'cfg(target_arch = "wasm32")'.dependencies]
-instant = "0.1"
+instant.workspace = true
[dev-dependencies]
approx = "0.5"