summaryrefslogtreecommitdiffstats
path: root/core/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2019-11-17 07:02:38 +0100
committerLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2019-11-17 07:02:38 +0100
commite0bdb203f2596a65b6ce8c6fb939f82a6dc24048 (patch)
tree522718443bbf58250b9a0da603ef9382e24410b4 /core/Cargo.toml
parent2cbd5d60c46d956fcab685b448a40c1aa5f5b69f (diff)
downloadiced-e0bdb203f2596a65b6ce8c6fb939f82a6dc24048.tar.gz
iced-e0bdb203f2596a65b6ce8c6fb939f82a6dc24048.tar.bz2
iced-e0bdb203f2596a65b6ce8c6fb939f82a6dc24048.zip
Implement future-based `Command` in `iced_core`
Diffstat (limited to 'core/Cargo.toml')
-rw-r--r--core/Cargo.toml7
1 files changed, 7 insertions, 0 deletions
diff --git a/core/Cargo.toml b/core/Cargo.toml
index a244bcba..f2492345 100644
--- a/core/Cargo.toml
+++ b/core/Cargo.toml
@@ -6,3 +6,10 @@ edition = "2018"
description = "The essential concepts of Iced"
license = "MIT"
repository = "https://github.com/hecrj/iced"
+
+[features]
+# Exposes a future-based `Command` type
+command = ["futures"]
+
+[dependencies]
+futures = { version = "0.3", optional = true }