summaryrefslogtreecommitdiffstats
path: root/core/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2020-01-19 09:06:48 +0100
committerLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2020-01-19 09:06:48 +0100
commitd50ff9b5d97d9c3d6c6c70a9b4efe764b6126c86 (patch)
treee5d176cddb6ef341d4050effc490e98988cf22d9 /core/Cargo.toml
parent32f7ca261f0655938ae7c8919599b020ddea8ff8 (diff)
downloadiced-d50ff9b5d97d9c3d6c6c70a9b4efe764b6126c86.tar.gz
iced-d50ff9b5d97d9c3d6c6c70a9b4efe764b6126c86.tar.bz2
iced-d50ff9b5d97d9c3d6c6c70a9b4efe764b6126c86.zip
Implement `Runtime` and `Executor` in `iced_core`
They can be leveraged by shells to easily execute commands and track subscriptions.
Diffstat (limited to 'core/Cargo.toml')
-rw-r--r--core/Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/core/Cargo.toml b/core/Cargo.toml
index 4e019ba9..5e1a5532 100644
--- a/core/Cargo.toml
+++ b/core/Cargo.toml
@@ -12,6 +12,8 @@ repository = "https://github.com/hecrj/iced"
command = ["futures"]
# Exposes a future-based `Subscription` type
subscription = ["futures", "log"]
+# Exposes a `runtime` module meant to abstract over different future executors
+runtime = ["command", "subscription"]
[dependencies]
futures = { version = "0.3", optional = true }