summaryrefslogtreecommitdiffstats
path: root/core/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2019-09-10 19:41:49 +0200
committerLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2019-09-10 19:41:49 +0200
commit8b8f7563ad33dafeadf6238e377748cdec17d67a (patch)
tree45a601d18a054ccdd068eeac93730e4e99252158 /core/Cargo.toml
parent2913c64da3452d1fbf92384e4ff32c278fb383f8 (diff)
downloadiced-8b8f7563ad33dafeadf6238e377748cdec17d67a.tar.gz
iced-8b8f7563ad33dafeadf6238e377748cdec17d67a.tar.bz2
iced-8b8f7563ad33dafeadf6238e377748cdec17d67a.zip
Switch to workspace layout
Diffstat (limited to 'core/Cargo.toml')
-rw-r--r--core/Cargo.toml25
1 files changed, 25 insertions, 0 deletions
diff --git a/core/Cargo.toml b/core/Cargo.toml
new file mode 100644
index 00000000..cd84d03e
--- /dev/null
+++ b/core/Cargo.toml
@@ -0,0 +1,25 @@
+[package]
+name = "iced"
+version = "0.1.0-alpha"
+authors = ["Héctor Ramón Jiménez <hector0193@gmail.com>"]
+edition = "2018"
+description = "A GUI runtime, heavily inspired by Elm."
+license = "MIT"
+repository = "https://github.com/hecrj/iced"
+documentation = "https://docs.rs/iced"
+readme = "README.md"
+keywords = ["gui", "ui", "graphics", "interface", "widgets"]
+categories = ["gui"]
+
+[badges]
+maintenance = { status = "actively-developed" }
+
+[package.metadata.docs.rs]
+features = ["winit"]
+
+[dependencies]
+stretch = "0.2"
+twox-hash = "1.5"
+
+# Enable to obtain conversion traits
+winit = { version = "0.20.0-alpha3", optional = true }