summaryrefslogtreecommitdiffstats
path: root/core/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Gigas002 <24297712+Gigas002@users.noreply.github.com>2024-03-24 11:13:45 +0900
committerLibravatar GitHub <noreply@github.com>2024-03-24 11:13:45 +0900
commit4334e63ba1dd88b367f3b7f2790b7869d11d12c0 (patch)
tree7a02d84426a54a5a5283f5ad101cc803442998fd /core/Cargo.toml
parentf3a1c785b2743e9c48c3d28df0c6772ce579d7c8 (diff)
parent3013463baa71504488a20436beb3db87ecb66df0 (diff)
downloadiced-4334e63ba1dd88b367f3b7f2790b7869d11d12c0.tar.gz
iced-4334e63ba1dd88b367f3b7f2790b7869d11d12c0.tar.bz2
iced-4334e63ba1dd88b367f3b7f2790b7869d11d12c0.zip
Merge branch 'iced-rs:master' into viewer_content_fit
Diffstat (limited to 'core/Cargo.toml')
-rw-r--r--core/Cargo.toml6
1 files changed, 6 insertions, 0 deletions
diff --git a/core/Cargo.toml b/core/Cargo.toml
index c273fcb4..29a95ad7 100644
--- a/core/Cargo.toml
+++ b/core/Cargo.toml
@@ -10,6 +10,9 @@ homepage.workspace = true
categories.workspace = true
keywords.workspace = true
+[features]
+auto-detect-theme = ["dep:dark-light"]
+
[dependencies]
bitflags.workspace = true
glam.workspace = true
@@ -22,6 +25,9 @@ thiserror.workspace = true
web-time.workspace = true
xxhash-rust.workspace = true
+dark-light.workspace = true
+dark-light.optional = true
+
[target.'cfg(windows)'.dependencies]
raw-window-handle.workspace = true