summaryrefslogtreecommitdiffstats
path: root/core/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón <hector@hecrj.dev>2024-03-20 16:44:50 +0100
committerLibravatar GitHub <noreply@github.com>2024-03-20 16:44:50 +0100
commit2b00e8b1457b0ccbafe12db3dbd6431c2c72f275 (patch)
tree3df829ecf6128115800a8f44c899b1743383c7f1 /core/Cargo.toml
parentaf6bc4643df83c4695f0954aa3fdd258988a77cf (diff)
parent9db6ac8f202ebdc1453edee01da0b30aee0949d8 (diff)
downloadiced-2b00e8b1457b0ccbafe12db3dbd6431c2c72f275.tar.gz
iced-2b00e8b1457b0ccbafe12db3dbd6431c2c72f275.tar.bz2
iced-2b00e8b1457b0ccbafe12db3dbd6431c2c72f275.zip
Merge pull request #2343 from iced-rs/auto-detect-theme
Introduce `auto-detect-theme` feature
Diffstat (limited to 'core/Cargo.toml')
-rw-r--r--core/Cargo.toml6
1 files changed, 6 insertions, 0 deletions
diff --git a/core/Cargo.toml b/core/Cargo.toml
index c273fcb4..29a95ad7 100644
--- a/core/Cargo.toml
+++ b/core/Cargo.toml
@@ -10,6 +10,9 @@ homepage.workspace = true
categories.workspace = true
keywords.workspace = true
+[features]
+auto-detect-theme = ["dep:dark-light"]
+
[dependencies]
bitflags.workspace = true
glam.workspace = true
@@ -22,6 +25,9 @@ thiserror.workspace = true
web-time.workspace = true
xxhash-rust.workspace = true
+dark-light.workspace = true
+dark-light.optional = true
+
[target.'cfg(windows)'.dependencies]
raw-window-handle.workspace = true