summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón Jiménez <hector@hecrj.dev>2023-09-19 20:48:50 +0200
committerLibravatar Héctor Ramón Jiménez <hector@hecrj.dev>2023-09-19 20:48:50 +0200
commitf806d001e6fb44b5a45029ca257261e6e0d4d4b2 (patch)
tree4a9292fde7f8db76915d3596d326eb71ff7b92a9 /Cargo.toml
parentc0a141ab026f5686d6bd92c8807b174396cb9105 (diff)
downloadiced-f806d001e6fb44b5a45029ca257261e6e0d4d4b2.tar.gz
iced-f806d001e6fb44b5a45029ca257261e6e0d4d4b2.tar.bz2
iced-f806d001e6fb44b5a45029ca257261e6e0d4d4b2.zip
Introduce new `iced_highlighter` subcrate
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml10
1 files changed, 9 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index e887afc0..8899fa67 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -47,6 +47,8 @@ system = ["iced_winit/system"]
web-colors = ["iced_renderer/web-colors"]
# Enables the WebGL backend, replacing WebGPU
webgl = ["iced_renderer/webgl"]
+# Enables the syntax `highlighter` module
+highlighter = ["iced_highlighter"]
# Enables the advanced module
advanced = []
@@ -58,6 +60,9 @@ iced_widget.workspace = true
iced_winit.features = ["application"]
iced_winit.workspace = true
+iced_highlighter.workspace = true
+iced_highlighter.optional = true
+
thiserror.workspace = true
image.workspace = true
@@ -78,8 +83,9 @@ members = [
"core",
"futures",
"graphics",
- "runtime",
+ "highlighter",
"renderer",
+ "runtime",
"style",
"tiny_skia",
"wgpu",
@@ -103,6 +109,7 @@ iced = { version = "0.12", path = "." }
iced_core = { version = "0.12", path = "core" }
iced_futures = { version = "0.12", path = "futures" }
iced_graphics = { version = "0.12", path = "graphics" }
+iced_highlighter = { version = "0.12", path = "highlighter" }
iced_renderer = { version = "0.12", path = "renderer" }
iced_runtime = { version = "0.12", path = "runtime" }
iced_style = { version = "0.12", path = "style" }
@@ -137,6 +144,7 @@ resvg = "0.35"
rustc-hash = "1.0"
smol = "1.0"
softbuffer = "0.2"
+syntect = "5.1"
sysinfo = "0.28"
thiserror = "1.0"
tiny-skia = "0.10"