summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar daladim <daladim@users.noreply.github.com>2021-12-29 00:15:18 +0100
committerLibravatar daladim <daladim@users.noreply.github.com>2022-03-01 22:15:16 +0100
commitf3e7781cb1bb7a70f5c87ea37b13ac248b50cc0a (patch)
treebde7e96792533efe8457050073daed1fcaf96733 /Cargo.toml
parentee6f4cb2ac7f322ef708fe0655835638bac841ea (diff)
downloadiced-f3e7781cb1bb7a70f5c87ea37b13ac248b50cc0a.tar.gz
iced-f3e7781cb1bb7a70f5c87ea37b13ac248b50cc0a.tar.bz2
iced-f3e7781cb1bb7a70f5c87ea37b13ac248b50cc0a.zip
Added convenience functions for window::icon::Icon
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml7
1 files changed, 6 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 7c222fbb..60c60fbb 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -17,7 +17,7 @@ default = ["wgpu"]
# Enables the `iced_wgpu` renderer
wgpu = ["iced_wgpu"]
# Enables the `Image` widget
-image = ["iced_wgpu/image"]
+image = ["iced_wgpu/image", "image_rs"]
# Enables the `Svg` widget
svg = ["iced_wgpu/svg"]
# Enables the `Canvas` widget
@@ -98,6 +98,11 @@ iced_glutin = { version = "0.2", path = "glutin", optional = true }
iced_glow = { version = "0.2", path = "glow", optional = true }
thiserror = "1.0"
+[dependencies.image_rs]
+version = "0.23"
+package = "image"
+optional = true
+
[target.'cfg(not(target_arch = "wasm32"))'.dependencies]
iced_wgpu = { version = "0.4", path = "wgpu", optional = true }