summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2019-10-03 00:01:45 +0200
committerLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2019-10-03 00:01:45 +0200
commite1b9d42bf1443ae4958aa9303255ef19c635debb (patch)
treea7b7615dabc328a90300488ab8623740417277c8 /Cargo.toml
parent67d3fe67f312c4dfe9fe4af0f0cbc7cb23c30072 (diff)
downloadiced-e1b9d42bf1443ae4958aa9303255ef19c635debb.tar.gz
iced-e1b9d42bf1443ae4958aa9303255ef19c635debb.tar.bz2
iced-e1b9d42bf1443ae4958aa9303255ef19c635debb.zip
Start `iced_winit` and `iced_wgpu`
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml9
1 files changed, 8 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 0975aeeb..4792b3ad 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "iced"
-version = "0.1.0-alpha"
+version = "0.1.0-alpha.1"
authors = ["Héctor Ramón Jiménez <hector0193@gmail.com>"]
edition = "2018"
description = "A cross-platform GUI library inspired by Elm"
@@ -21,3 +21,10 @@ members = [
"web",
"examples/tour",
]
+
+[target.'cfg(not(target_arch = "wasm32"))'.dependencies]
+iced_winit = { version = "0.1.0-alpha", path = "winit" }
+iced_wgpu = { version = "0.1.0-alpha", path = "wgpu" }
+
+[target.'cfg(target_arch = "wasm32")'.dependencies]
+iced_web = { version = "0.1.0-alpha", path = "web" }