summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2020-05-21 00:37:47 +0200
committerLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2020-05-21 00:44:35 +0200
commite0e4ee73feead3f05730625c7e1917b63f0b384e (patch)
tree5cd934cc474a5aacc60359f6fe69a5b9d31fe45b /Cargo.toml
parenta1a5fcfd46622d5b18d1716aa2adb4659835ccf3 (diff)
downloadiced-e0e4ee73feead3f05730625c7e1917b63f0b384e.tar.gz
iced-e0e4ee73feead3f05730625c7e1917b63f0b384e.tar.bz2
iced-e0e4ee73feead3f05730625c7e1917b63f0b384e.zip
Implement `iced_glutin` :tada:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml13
1 files changed, 7 insertions, 6 deletions
diff --git a/Cargo.toml b/Cargo.toml
index aa6216cf..9339f4ed 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -13,13 +13,13 @@ categories = ["gui"]
[features]
# Enables the `Image` widget
-image = ["iced_wgpu/image"]
+image = ["iced_glow/image"]
# Enables the `Svg` widget
-svg = ["iced_wgpu/svg"]
+svg = ["iced_glow/svg"]
# Enables the `Canvas` widget
-canvas = ["iced_wgpu/canvas"]
+canvas = ["iced_glow/canvas"]
# Enables a debug view in native platforms (press F12)
-debug = ["iced_winit/debug"]
+debug = ["iced_glutin/debug"]
# Enables `tokio` as the `executor::Default` on native platforms
tokio = ["iced_futures/tokio"]
# Enables `async-std` as the `executor::Default` on native platforms
@@ -36,6 +36,7 @@ members = [
"futures",
"graphics",
"glow",
+ "glutin",
"native",
"style",
"web",
@@ -67,8 +68,8 @@ iced_core = { version = "0.2", path = "core" }
iced_futures = { version = "0.1", path = "futures" }
[target.'cfg(not(target_arch = "wasm32"))'.dependencies]
-iced_winit = { version = "0.1", path = "winit" }
-iced_wgpu = { version = "0.2", path = "wgpu" }
+iced_glutin = { version = "0.1", path = "glutin" }
+iced_glow = { version = "0.1", path = "glow" }
[target.'cfg(target_arch = "wasm32")'.dependencies]
iced_web = { version = "0.2", path = "web" }