diff options
author | 2020-06-01 21:47:45 +0200 | |
---|---|---|
committer | 2020-06-01 21:47:45 +0200 | |
commit | d34f8e06c8e3cdbba07a272f346163cfc0f920a6 (patch) | |
tree | 87da05d984bbac2458c41caf0cea8c5b2cc26c46 /Cargo.toml | |
parent | 05750bf1863f8a6d2b797c4c482cd38dc45d7aeb (diff) | |
parent | 86f0e3d4e244710eb925c8603368d191aa7daff7 (diff) | |
download | iced-d34f8e06c8e3cdbba07a272f346163cfc0f920a6.tar.gz iced-d34f8e06c8e3cdbba07a272f346163cfc0f920a6.tar.bz2 iced-d34f8e06c8e3cdbba07a272f346163cfc0f920a6.zip |
Merge pull request #370 from azriel91/improvement/58/feature-gate-font-kit
Improvement/58/feature gate font kit
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 6 |
1 files changed, 5 insertions, 1 deletions
@@ -12,7 +12,7 @@ keywords = ["gui", "ui", "graphics", "interface", "widgets"] categories = ["gui"] [features] -default = ["wgpu"] +default = ["wgpu", "default_system_font"] # Enables the `iced_wgpu` renderer wgpu = ["iced_wgpu"] # Enables the `Image` widget @@ -21,10 +21,14 @@ image = ["iced_wgpu/image"] svg = ["iced_wgpu/svg"] # Enables the `Canvas` widget canvas = ["iced_wgpu/canvas"] +# Enables using system fonts. +default_system_font = ["iced_wgpu/default_system_font"] # Enables the `iced_glow` renderer. Overrides `iced_wgpu` glow = ["iced_glow", "iced_glutin"] # Enables the `Canvas` widget for `iced_glow` glow_canvas = ["iced_glow/canvas"] +# Enables using system fonts for `iced_glow`. +glow_default_system_font = ["iced_glow/default_system_font"] # Enables a debug view in native platforms (press F12) debug = ["iced_winit/debug"] # Enables `tokio` as the `executor::Default` on native platforms |