diff options
author | 2022-11-29 19:50:58 -0800 | |
---|---|---|
committer | 2023-01-09 18:52:38 +0100 | |
commit | c5cd236b7380c3689792934aeaecd2942713fa67 (patch) | |
tree | c27a0e6ecfdec7936791ee70e07ce19c713095cd /Cargo.toml | |
parent | ba20ac8e49aedfa9d822d71784587d0635cec4f8 (diff) | |
download | iced-c5cd236b7380c3689792934aeaecd2942713fa67.tar.gz iced-c5cd236b7380c3689792934aeaecd2942713fa67.tar.bz2 iced-c5cd236b7380c3689792934aeaecd2942713fa67.zip |
Initial profiling support for Iced.
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 10 |
1 files changed, 10 insertions, 0 deletions
@@ -39,6 +39,14 @@ smol = ["iced_futures/smol"] palette = ["iced_core/palette"] # Enables querying system information system = ["iced_winit/system"] +# Enables tracing with Chrome +trace_chrome = [ + "iced_winit/trace", + "iced_wgpu?/trace", + "iced_glow?/trace", + "iced_glutin?/trace", + "iced_profiling/tracing-chrome" +] [badges] maintenance = { status = "actively-developed" } @@ -51,6 +59,7 @@ members = [ "glow", "glutin", "lazy", + "profiling", "native", "style", "wgpu", @@ -66,6 +75,7 @@ iced_graphics = { version = "0.5", path = "graphics" } iced_winit = { version = "0.6", path = "winit", features = ["application"] } iced_glutin = { version = "0.5", path = "glutin", optional = true } iced_glow = { version = "0.5", path = "glow", optional = true } +iced_profiling = { version = "0.1.0", path = "profiling", optional = true } thiserror = "1.0" [dependencies.image_rs] |