summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón <hector0193@gmail.com>2022-09-23 20:02:57 +0200
committerLibravatar GitHub <noreply@github.com>2022-09-23 20:02:57 +0200
commitbfd24c27db3d37d4fb772d1ea564c96936663c1d (patch)
treef45beee344201da3c6f66364eb20ab91f603d62c /Cargo.toml
parent489a85518b4b533d92f59b468634cec5194ff567 (diff)
parentf3e7781cb1bb7a70f5c87ea37b13ac248b50cc0a (diff)
downloadiced-bfd24c27db3d37d4fb772d1ea564c96936663c1d.tar.gz
iced-bfd24c27db3d37d4fb772d1ea564c96936663c1d.tar.bz2
iced-bfd24c27db3d37d4fb772d1ea564c96936663c1d.zip
Merge pull request #1174 from daladim/icon_from_file
Added convenience functions for window::icon::Icon
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml7
1 files changed, 6 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 39a3b5cf..cffa5409 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -15,7 +15,7 @@ resolver = "2"
[features]
default = ["wgpu"]
# Enables the `Image` widget
-image = ["iced_wgpu/image"]
+image = ["iced_wgpu/image", "image_rs"]
# Enables the `Svg` widget
svg = ["iced_wgpu/svg"]
# Enables the `Canvas` widget
@@ -101,6 +101,11 @@ iced_glutin = { version = "0.3", path = "glutin", optional = true }
iced_glow = { version = "0.3", path = "glow", optional = true }
thiserror = "1.0"
+[dependencies.image_rs]
+version = "0.23"
+package = "image"
+optional = true
+
[target.'cfg(not(target_arch = "wasm32"))'.dependencies]
iced_wgpu = { version = "0.5", path = "wgpu", optional = true }