summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2020-01-20 11:19:42 +0100
committerLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2020-01-20 11:19:42 +0100
commitbc611cf51cd35bb3a4b91500c8a13202db58ac38 (patch)
tree38d04730584ca63fac40e8902eaf03b01bc077fe /Cargo.toml
parent91d9d65a03ce9b211e4043726e7424949d314325 (diff)
downloadiced-bc611cf51cd35bb3a4b91500c8a13202db58ac38.tar.gz
iced-bc611cf51cd35bb3a4b91500c8a13202db58ac38.tar.bz2
iced-bc611cf51cd35bb3a4b91500c8a13202db58ac38.zip
Make `image` support optional in `iced_wgpu`
This reduces binary size when image rendering is not necessary a considerable amount.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml6
1 files changed, 4 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 28a97af9..7bfce09a 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -12,10 +12,12 @@ keywords = ["gui", "ui", "graphics", "interface", "widgets"]
categories = ["gui"]
[features]
+# Enables the Image widget
+image = ["iced_wgpu/image"]
+# Enables the Svg widget
+svg = ["iced_wgpu/svg"]
# Enables a debug view in native platforms (press F12)
debug = ["iced_winit/debug"]
-# Enables support for SVG rendering
-svg = ["iced_wgpu/svg"]
[badges]
maintenance = { status = "actively-developed" }