summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón <hector@hecrj.dev>2024-09-20 01:27:08 +0200
committerLibravatar GitHub <noreply@github.com>2024-09-20 01:27:08 +0200
commitb78b8bc8e3c8dcb778b4e76bb9ef0ab1b88f633d (patch)
tree90a35a189a431adaff0d7121f12fbdf268083c67 /Cargo.toml
parentfed9c8d19bed572aec80376722fc5ef0d48ac417 (diff)
parent84b658dbef0b29c57f67e041a1496c699ce78615 (diff)
downloadiced-b78b8bc8e3c8dcb778b4e76bb9ef0ab1b88f633d.tar.gz
iced-b78b8bc8e3c8dcb778b4e76bb9ef0ab1b88f633d.tar.bz2
iced-b78b8bc8e3c8dcb778b4e76bb9ef0ab1b88f633d.zip
Merge pull request #2510 from iced-rs/wgpu-22.0
Update `wgpu` to `22.0`
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml6
1 files changed, 4 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 6de4f4bf..bee83d2e 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -65,6 +65,8 @@ advanced = ["iced_core/advanced", "iced_widget/advanced"]
fira-sans = ["iced_renderer/fira-sans"]
# Enables auto-detecting light/dark mode for the built-in theme
auto-detect-theme = ["iced_core/auto-detect-theme"]
+# Enables strict assertions for debugging purposes at the expense of performance
+strict-assertions = ["iced_renderer/strict-assertions"]
[dependencies]
iced_core.workspace = true
@@ -148,7 +150,7 @@ cosmic-text = "0.12"
dark-light = "1.0"
futures = "0.3"
glam = "0.25"
-glyphon = { git = "https://github.com/hecrj/glyphon.git", rev = "feef9f5630c2adb3528937e55f7bfad2da561a65" }
+glyphon = { git = "https://github.com/hecrj/glyphon.git", rev = "0d7ba1bba4dd71eb88d2cface5ce649db2413cb7" }
guillotiere = "0.6"
half = "2.2"
image = { version = "0.24", default-features = false }
@@ -181,7 +183,7 @@ wasm-bindgen-futures = "0.4"
wasm-timer = "0.2"
web-sys = "0.3.69"
web-time = "1.1"
-wgpu = "0.19"
+wgpu = "22.0"
winapi = "0.3"
window_clipboard = "0.4.1"
winit = { git = "https://github.com/iced-rs/winit.git", rev = "254d6b3420ce4e674f516f7a2bd440665e05484d" }