summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2023-02-10 22:36:02 +0100
committerLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2023-02-24 13:39:38 +0100
commitb2c87cdd238baa1562dc0422c00d1bf62132700f (patch)
tree752bcb92e492ad404fcdd48edb26cc5fea346db1 /Cargo.toml
parenta0597471b81b122b43e1bb90e43e1bcde1e8a892 (diff)
downloadiced-b2c87cdd238baa1562dc0422c00d1bf62132700f.tar.gz
iced-b2c87cdd238baa1562dc0422c00d1bf62132700f.tar.bz2
iced-b2c87cdd238baa1562dc0422c00d1bf62132700f.zip
Make `iced_wgpu` a mandatory dependency
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml13
1 files changed, 5 insertions, 8 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 5fc0cc10..551e12ac 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -12,17 +12,14 @@ keywords = ["gui", "ui", "graphics", "interface", "widgets"]
categories = ["gui"]
[features]
-default = ["wgpu"]
# Enables the `Image` widget
-image = ["iced_wgpu?/image", "image_rs"]
+image = ["iced_wgpu/image", "image_rs"]
# Enables the `Svg` widget
-svg = ["iced_wgpu?/svg"]
+svg = ["iced_wgpu/svg"]
# Enables the `Canvas` widget
canvas = ["iced_graphics/canvas"]
# Enables the `QRCode` widget
qr_code = ["iced_graphics/qr_code"]
-# Enables the `iced_wgpu` renderer
-wgpu = ["iced_wgpu"]
# Enables a debug view in native platforms (press F12)
debug = ["iced_winit/debug"]
# Enables `tokio` as the `executor::Default` on native platforms
@@ -38,7 +35,7 @@ system = ["iced_winit/system"]
# Enables chrome traces
chrome-trace = [
"iced_winit/chrome-trace",
- "iced_wgpu?/tracing",
+ "iced_wgpu/tracing",
]
[badges]
@@ -71,10 +68,10 @@ package = "image"
optional = true
[target.'cfg(not(target_arch = "wasm32"))'.dependencies]
-iced_wgpu = { version = "0.9", path = "wgpu", optional = true }
+iced_wgpu = { version = "0.9", path = "wgpu" }
[target.'cfg(target_arch = "wasm32")'.dependencies]
-iced_wgpu = { version = "0.9", path = "wgpu", features = ["webgl"], optional = true }
+iced_wgpu = { version = "0.9", path = "wgpu", features = ["webgl"] }
[package.metadata.docs.rs]
rustdoc-args = ["--cfg", "docsrs"]