diff options
author | 2020-05-30 19:23:16 +1200 | |
---|---|---|
committer | 2020-05-31 11:00:17 +1200 | |
commit | ae9521e500d97c9495003a727b6fd931671dda8b (patch) | |
tree | 1141f65a3d41662b834fe8e26629b0402bcd4c57 /Cargo.toml | |
parent | 05750bf1863f8a6d2b797c4c482cd38dc45d7aeb (diff) | |
download | iced-ae9521e500d97c9495003a727b6fd931671dda8b.tar.gz iced-ae9521e500d97c9495003a727b6fd931671dda8b.tar.bz2 iced-ae9521e500d97c9495003a727b6fd931671dda8b.zip |
Feature gate `font-kit` behind `"default_system_font"` feature.
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 6 |
1 files changed, 5 insertions, 1 deletions
@@ -12,7 +12,7 @@ keywords = ["gui", "ui", "graphics", "interface", "widgets"] categories = ["gui"] [features] -default = ["wgpu"] +default = ["wgpu", "default_system_font"] # Enables the `iced_wgpu` renderer wgpu = ["iced_wgpu"] # Enables the `Image` widget @@ -21,10 +21,14 @@ image = ["iced_wgpu/image"] svg = ["iced_wgpu/svg"] # Enables the `Canvas` widget canvas = ["iced_wgpu/canvas"] +# Enables using system fonts. +default_system_font = ["iced_wgpu/default_system_font"] # Enables the `iced_glow` renderer. Overrides `iced_wgpu` glow = ["iced_glow", "iced_glutin"] # Enables the `Canvas` widget for `iced_glow` glow_canvas = ["iced_glow/canvas"] +# Enables using system fonts for `iced_glow`. +glow_default_system_font = ["iced_glow/default_system_font"] # Enables a debug view in native platforms (press F12) debug = ["iced_winit/debug"] # Enables `tokio` as the `executor::Default` on native platforms |