diff options
author | 2020-02-06 03:56:21 +0100 | |
---|---|---|
committer | 2020-02-06 03:56:21 +0100 | |
commit | ad500441afc355f0b8ca2a463248d350d74f0f20 (patch) | |
tree | 66d58de7d3ab822db12118e22554ad883da3cc30 /Cargo.toml | |
parent | e8316b208705910958152b2ef6c4c5d7110b4e6c (diff) | |
download | iced-ad500441afc355f0b8ca2a463248d350d74f0f20.tar.gz iced-ad500441afc355f0b8ca2a463248d350d74f0f20.tar.bz2 iced-ad500441afc355f0b8ca2a463248d350d74f0f20.zip |
Allow switching `executor::Default` with features
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 11 |
1 files changed, 9 insertions, 2 deletions
@@ -12,12 +12,16 @@ keywords = ["gui", "ui", "graphics", "interface", "widgets"] categories = ["gui"] [features] -# Enables the Image widget +# Enables the `Image` widget image = ["iced_wgpu/image"] -# Enables the Svg widget +# Enables the `Svg` widget svg = ["iced_wgpu/svg"] # Enables a debug view in native platforms (press F12) debug = ["iced_winit/debug"] +# Enables `tokio` as the `executor::Default` on native platforms +tokio = ["iced_futures/tokio"] +# Enables `async-std` as the `executor::Default` on native platforms +async-std = ["iced_futures/async-std"] [badges] maintenance = { status = "actively-developed" } @@ -45,6 +49,9 @@ members = [ "examples/tour", ] +[dependencies] +iced_futures = { version = "0.1.0-alpha", path = "futures" } + [target.'cfg(not(target_arch = "wasm32"))'.dependencies] iced_winit = { version = "0.1.0-alpha", path = "winit" } iced_wgpu = { version = "0.1.0", path = "wgpu" } |