summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón <hector0193@gmail.com>2022-11-08 04:24:48 +0100
committerLibravatar GitHub <noreply@github.com>2022-11-08 04:24:48 +0100
commitacb520a4a8001ed9db885d128ddd1f0ccbd71db2 (patch)
treeaa52acd615a76ef04bcacff4b9ad20cfe4595a59 /Cargo.toml
parentda2325d18df661edd20cac486233997f29be73b6 (diff)
parent4d42ca2452cd270dfcfbdb03836c5857a3c28f73 (diff)
downloadiced-acb520a4a8001ed9db885d128ddd1f0ccbd71db2.tar.gz
iced-acb520a4a8001ed9db885d128ddd1f0ccbd71db2.tar.bz2
iced-acb520a4a8001ed9db885d128ddd1f0ccbd71db2.zip
Merge pull request #1505 from ids1024/weak-dep-feature
Combine `glow_default_system_font` and `default_system_font` features
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 1 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 386eab48..ff59d7a9 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -10,7 +10,6 @@ documentation = "https://docs.rs/iced"
readme = "README.md"
keywords = ["gui", "ui", "graphics", "interface", "widgets"]
categories = ["gui"]
-resolver = "2"
[features]
default = ["wgpu"]
@@ -25,11 +24,9 @@ qr_code = ["iced_graphics/qr_code"]
# Enables the `iced_wgpu` renderer
wgpu = ["iced_wgpu"]
# Enables using system fonts
-default_system_font = ["iced_wgpu/default_system_font"]
+default_system_font = ["iced_wgpu?/default_system_font", "iced_glow?/default_system_font"]
# Enables the `iced_glow` renderer. Overrides `iced_wgpu`
glow = ["iced_glow", "iced_glutin"]
-# Enables using system fonts for `iced_glow`
-glow_default_system_font = ["iced_glow/default_system_font"]
# Enables a debug view in native platforms (press F12)
debug = ["iced_winit/debug"]
# Enables `tokio` as the `executor::Default` on native platforms