summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón Jiménez <hector@hecrj.dev>2024-03-19 23:58:17 +0100
committerLibravatar Héctor Ramón Jiménez <hector@hecrj.dev>2024-03-20 00:02:46 +0100
commit9db6ac8f202ebdc1453edee01da0b30aee0949d8 (patch)
tree3df829ecf6128115800a8f44c899b1743383c7f1 /Cargo.toml
parentaf6bc4643df83c4695f0954aa3fdd258988a77cf (diff)
downloadiced-9db6ac8f202ebdc1453edee01da0b30aee0949d8.tar.gz
iced-9db6ac8f202ebdc1453edee01da0b30aee0949d8.tar.bz2
iced-9db6ac8f202ebdc1453edee01da0b30aee0949d8.zip
Introduce `auto-detect-theme` feature
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml6
1 files changed, 5 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 3638102b..b82c0f67 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -18,7 +18,7 @@ all-features = true
maintenance = { status = "actively-developed" }
[features]
-default = ["wgpu", "fira-sans"]
+default = ["wgpu", "fira-sans", "auto-detect-theme"]
# Enable the `wgpu` GPU-accelerated renderer backend
wgpu = ["iced_renderer/wgpu", "iced_widget/wgpu"]
# Enables the `Image` widget
@@ -53,8 +53,11 @@ multi-window = ["iced_winit/multi-window"]
advanced = []
# Enables embedding Fira Sans as the default font on Wasm builds
fira-sans = ["iced_renderer/fira-sans"]
+# Enables auto-detecting light/dark mode for the built-in theme
+auto-detect-theme = ["iced_core/auto-detect-theme"]
[dependencies]
+iced_core.workspace = true
iced_futures.workspace = true
iced_renderer.workspace = true
iced_widget.workspace = true
@@ -121,6 +124,7 @@ async-std = "1.0"
bitflags = "2.0"
bytemuck = { version = "1.0", features = ["derive"] }
cosmic-text = "0.10"
+dark-light = "1.0"
futures = "0.3"
glam = "0.25"
glyphon = "0.5"