diff options
author | 2023-03-06 22:10:13 +0100 | |
---|---|---|
committer | 2023-03-06 22:10:13 +0100 | |
commit | 9b4bcd287a7f4822314e158990d1dc023d5aab51 (patch) | |
tree | c331392327cbe15214cd6ffef6ccae4c491dc9d1 /Cargo.toml | |
parent | 06bbcc310e6e759a0839df6ca391ea5e0f0ee609 (diff) | |
download | iced-9b4bcd287a7f4822314e158990d1dc023d5aab51.tar.gz iced-9b4bcd287a7f4822314e158990d1dc023d5aab51.tar.bz2 iced-9b4bcd287a7f4822314e158990d1dc023d5aab51.zip |
Introduce backend feature flags in `iced_renderer`
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 6 |
1 files changed, 6 insertions, 0 deletions
@@ -12,6 +12,11 @@ keywords = ["gui", "ui", "graphics", "interface", "widgets"] categories = ["gui"] [features] +default = ["wgpu", "tiny-skia"] +# Enable the `wgpu` GPU-accelerated renderer backend +wgpu = ["iced_renderer/wgpu"] +# Enable the `tiny-skia` software renderer backend +tiny-skia = ["iced_renderer/tiny-skia"] # Enables the `Image` widget image = ["iced_widget/image", "image_rs"] # Enables the `Svg` widget @@ -58,6 +63,7 @@ members = [ [dependencies] iced_core = { version = "0.8", path = "core" } iced_futures = { version = "0.6", path = "futures" } +iced_renderer = { version = "0.1", path = "renderer" } iced_widget = { version = "0.1", path = "widget" } iced_winit = { version = "0.8", path = "winit", features = ["application"] } thiserror = "1" |