diff options
author | 2022-02-09 19:42:15 +0700 | |
---|---|---|
committer | 2022-02-09 19:42:15 +0700 | |
commit | 8f0839e786f8d521f7319dd0e188d43284f526b7 (patch) | |
tree | 6d902f1f28f02842134c0a07139d7aa9dae5eb80 /Cargo.toml | |
parent | adce9e04213803bd775538efddf6e7908d1c605e (diff) | |
download | iced-8f0839e786f8d521f7319dd0e188d43284f526b7.tar.gz iced-8f0839e786f8d521f7319dd0e188d43284f526b7.tar.bz2 iced-8f0839e786f8d521f7319dd0e188d43284f526b7.zip |
Draft `iced_virtual` subcrate
The idea here is to expose a set of "virtual widgets" that can be used with a
`Virtual` widget and its `virtual::State`.
A virtual widget is a widget that does not contain any state, but instead is a
"virtual" representation of the "real" widget. The real widgets are stored in
the `virtual::State`.
Every time a new virtual widget tree is created during `view`, it is compared to
the previous one and "real" widgets are added / removed to the `virtual::State`.
Effectively, this removes the need to keep track of local widget state in the
application state and allows `view` to take an immutable reference to `self`.
To summarize, using this crate should allow users to remove `State` structs
in their application state.
Eventually, the strategy used here may be adopted generally and, as a result,
all of the widgets in `iced_native` would be replaced!
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 1 |
1 files changed, 1 insertions, 0 deletions
@@ -58,6 +58,7 @@ members = [ "lazy", "native", "style", + "virtual", "wgpu", "winit", "examples/bezier_tool", |