summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Luni-4 <luni-4@hotmail.it>2022-05-20 10:34:25 +0200
committerLibravatar Luni-4 <luni-4@hotmail.it>2022-07-14 16:58:06 +0200
commit8f03a727427bda5a1bfaf8c2969f651b9d021745 (patch)
tree98c1d4fb325f0981dea278a3eb44968773977944 /Cargo.toml
parente187d6ce7bd5e984950fa3e8aa36ccb1337edc9c (diff)
downloadiced-8f03a727427bda5a1bfaf8c2969f651b9d021745.tar.gz
iced-8f03a727427bda5a1bfaf8c2969f651b9d021745.tar.bz2
iced-8f03a727427bda5a1bfaf8c2969f651b9d021745.zip
Add custom profile release-opt
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml10
1 files changed, 10 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 9d90ca0d..56b4d06a 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -121,3 +121,13 @@ iced_wgpu = { version = "0.5", path = "wgpu", features = ["webgl"], optional = t
[package.metadata.docs.rs]
rustdoc-args = ["--cfg", "docsrs"]
features = ["image", "svg", "canvas", "qr_code", "pure"]
+
+[profile.release-opt]
+inherits = "release"
+codegen-units = 1
+debug = false
+lto = true
+incremental = false
+opt-level = 3
+overflow-checks = false
+strip = "debuginfo"