summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón Jiménez <hector@hecrj.dev>2024-01-18 09:55:27 +0100
committerLibravatar Héctor Ramón Jiménez <hector@hecrj.dev>2024-01-18 09:55:27 +0100
commit8bf238697226e827dc983f9d89afbd0e252c5254 (patch)
tree3594e998d60b130ab6b161aa00159e2311cbde0a /Cargo.toml
parent7289b6091b61b0aa448a756cfe32211c78a4cce0 (diff)
downloadiced-8bf238697226e827dc983f9d89afbd0e252c5254.tar.gz
iced-8bf238697226e827dc983f9d89afbd0e252c5254.tar.bz2
iced-8bf238697226e827dc983f9d89afbd0e252c5254.zip
Remove `Compositor` window generic
And update `glyphon` and `window_clipboard`
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml10
1 files changed, 3 insertions, 7 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 421c7c76..131a4ef5 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -128,10 +128,7 @@ bytemuck = { version = "1.0", features = ["derive"] }
cosmic-text = "0.10"
futures = "0.3"
glam = "0.24"
-# glyphon = "0.4"
-# TODO update for wgpu 0.19
-# https://github.com/grovesNL/glyphon/pull/80
-glyphon = { git = "https://github.com/EggShark/glyphon" }
+glyphon = "0.5"
guillotiere = "0.6"
half = "2.2"
image = "0.24"
@@ -165,6 +162,5 @@ web-sys = "0.3"
web-time = "0.2"
wgpu = "0.19"
winapi = "0.3"
-# window_clipboard = "0.3"
-window_clipboard = { git = "https://github.com/ids1024/window_clipboard", branch = "raw-window-handle-0.6" }
-winit = { git = "https://github.com/iced-rs/winit.git", rev = "b91e39ece2c0d378c3b80da7f3ab50e17bb798a5", features = ["rwh_06"] }
+window_clipboard = "0.4"
+winit = { git = "https://github.com/iced-rs/winit.git", rev = "b91e39ece2c0d378c3b80da7f3ab50e17bb798a5" }