summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón Jiménez <hector@hecrj.dev>2024-09-20 00:39:21 +0200
committerLibravatar Héctor Ramón Jiménez <hector@hecrj.dev>2024-09-20 00:59:45 +0200
commit84b658dbef0b29c57f67e041a1496c699ce78615 (patch)
tree90a35a189a431adaff0d7121f12fbdf268083c67 /Cargo.toml
parenta5e69cfb5f7856e4d139ef58e5d022b9d408b542 (diff)
downloadiced-84b658dbef0b29c57f67e041a1496c699ce78615.tar.gz
iced-84b658dbef0b29c57f67e041a1496c699ce78615.tar.bz2
iced-84b658dbef0b29c57f67e041a1496c699ce78615.zip
Introduce `strict-assertions` feature flag
For now, this feature flag only enables validation in `iced_wgpu`; which has become quite expensive since its `0.20` release.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 629b1c9d..bee83d2e 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -65,6 +65,8 @@ advanced = ["iced_core/advanced", "iced_widget/advanced"]
fira-sans = ["iced_renderer/fira-sans"]
# Enables auto-detecting light/dark mode for the built-in theme
auto-detect-theme = ["iced_core/auto-detect-theme"]
+# Enables strict assertions for debugging purposes at the expense of performance
+strict-assertions = ["iced_renderer/strict-assertions"]
[dependencies]
iced_core.workspace = true