summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2020-11-25 03:06:24 +0100
committerLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2020-11-25 03:06:24 +0100
commit782dd2f5222bfef5e12aa576a821da21126505b7 (patch)
treeef43d15531134d4c92dedca14682d70d0c614a00 /Cargo.toml
parenta4ad1b297e97d6c3efc196681822f127efc954cc (diff)
downloadiced-782dd2f5222bfef5e12aa576a821da21126505b7.tar.gz
iced-782dd2f5222bfef5e12aa576a821da21126505b7.tar.bz2
iced-782dd2f5222bfef5e12aa576a821da21126505b7.zip
Introduce `tokio_old` feature
This feature allows users to rely on the `0.2` version of `tokio` while the async ecosystem upgrades to the latest version.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index e201a4b6..90ac75bd 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -33,6 +33,8 @@ glow_default_system_font = ["iced_glow/default_system_font"]
debug = ["iced_winit/debug"]
# Enables `tokio` as the `executor::Default` on native platforms
tokio = ["iced_futures/tokio"]
+# Enables old `tokio` (0.2) as the `executor::Default` on native platforms
+tokio_old = ["iced_futures/tokio_old"]
# Enables `async-std` as the `executor::Default` on native platforms
async-std = ["iced_futures/async-std"]
# Enables advanced color conversion via `palette`