summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón <hector0193@gmail.com>2020-01-21 00:15:01 +0100
committerLibravatar GitHub <noreply@github.com>2020-01-21 00:15:01 +0100
commit7016221556ea8183ebcd8ef8df00044e2eda71e7 (patch)
treebc1609b71b88437fc7497af339b6427f63121c76 /Cargo.toml
parent6ca5e6184f9f1c12b427bdafcce0b4e9fbc5bb14 (diff)
parent91d9d65a03ce9b211e4043726e7424949d314325 (diff)
downloadiced-7016221556ea8183ebcd8ef8df00044e2eda71e7.tar.gz
iced-7016221556ea8183ebcd8ef8df00044e2eda71e7.tar.bz2
iced-7016221556ea8183ebcd8ef8df00044e2eda71e7.zip
Merge pull request #164 from hecrj/feature/custom-runtime
Custom futures executor with `iced_futures`
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml29
1 files changed, 13 insertions, 16 deletions
diff --git a/Cargo.toml b/Cargo.toml
index aeb8382e..28a97af9 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -23,11 +23,24 @@ maintenance = { status = "actively-developed" }
[workspace]
members = [
"core",
+ "futures",
"native",
"style",
"web",
"wgpu",
"winit",
+ "examples/bezier_tool",
+ "examples/counter",
+ "examples/custom_widget",
+ "examples/events",
+ "examples/geometry",
+ "examples/pokedex",
+ "examples/progress_bar",
+ "examples/stopwatch",
+ "examples/styling",
+ "examples/svg",
+ "examples/todos",
+ "examples/tour",
]
[target.'cfg(not(target_arch = "wasm32"))'.dependencies]
@@ -36,19 +49,3 @@ iced_wgpu = { version = "0.1.0", path = "wgpu" }
[target.'cfg(target_arch = "wasm32")'.dependencies]
iced_web = { version = "0.1.0", path = "web" }
-
-[dev-dependencies]
-iced_native = { version = "0.1", path = "./native" }
-iced_wgpu = { version = "0.1", path = "./wgpu" }
-env_logger = "0.7"
-serde = { version = "1.0", features = ["derive"] }
-serde_json = "1.0"
-directories = "2.0"
-futures = "0.3"
-async-std = { version = "1.3", features = ["unstable"] }
-surf = "1.0"
-rand = "0.7"
-lyon = "0.15"
-
-[target.'cfg(target_arch = "wasm32")'.dev-dependencies]
-wasm-bindgen = "0.2.51"