summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón <hector@hecrj.dev>2024-02-20 03:56:30 +0100
committerLibravatar GitHub <noreply@github.com>2024-02-20 03:56:30 +0100
commit698b9001b12bfb23fe1eccece62eae6417bea18a (patch)
tree3db828501fedac26342c41fcec05d0e9a7477f0f /Cargo.toml
parent0fe265adb0a97e64b0c83cbb19c7d0179bb60975 (diff)
parent35e2049ee668791f67b5325fc156b8c042d26d49 (diff)
downloadiced-698b9001b12bfb23fe1eccece62eae6417bea18a.tar.gz
iced-698b9001b12bfb23fe1eccece62eae6417bea18a.tar.bz2
iced-698b9001b12bfb23fe1eccece62eae6417bea18a.zip
Merge pull request #2271 from iced-rs/fix/wasm
Fix WebAssembly platform
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 3 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index ef7eae61..7d275b31 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -18,7 +18,7 @@ all-features = true
maintenance = { status = "actively-developed" }
[features]
-default = ["wgpu"]
+default = ["wgpu", "fira-sans"]
# Enable the `wgpu` GPU-accelerated renderer backend
wgpu = ["iced_renderer/wgpu", "iced_widget/wgpu"]
# Enables the `Image` widget
@@ -53,6 +53,8 @@ highlighter = ["iced_highlighter"]
multi-window = ["iced_winit/multi-window"]
# Enables the advanced module
advanced = []
+# Enables embedding Fira Sans as the default font on Wasm builds
+fira-sans = ["iced_renderer/fira-sans"]
[dependencies]
iced_core.workspace = true